Skip to content

← Actionable
Critical, CVSS 9.0amended

Prototype Pollution leading to Remote Code Execution in superjson

CVE-2022-23631GHSA-5888-ffcr-r425

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (blitz 0.45.3; superjson 1.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm blitz

    Affected
    < 0.45.3
    Fixed in
    0.45.3
  • npm superjson

    Affected
    < 1.8.1
    Fixed in
    1.8.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2022-23631: 2.68% estimated exploitation activity in the next 30 days; percentile 85.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This is critical vulnerability, as it allows to run arbitrary code on any server using superjson input, including a Blitz.js server, without prior authentication or knowledge. Attackers gain full control over the server so they could steal and manipulate data or attack further systems. The only requirement is that the server implements at least one endpoint which uses superjson during request processing. In the case of Blitz.js, it would be at least one RPC call. Patches This has been patched in superjson 1.8.1 and Blitz.js 0.45.3. If you are unable to upgrade to Blitz.js 0.45.3 in a timely manner, you can instead upgrade only superjson to version 1.8.1 using yarn resolutions are similar. Blitz versions < 0.45.3 are only affected because they used superjson versions < 1.8.1. Workarounds None For more information If you have any questions or comments about this advisory: Open an issue in https://github.com/blitz-js/superjson Email us at b@bayer.ws References…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5888-ffcr-r425

  2. Revision 1 · created ·

    Published from osv record GHSA-5888-ffcr-r425

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23631

Advisory: Prototype Pollution leading to Remote Code Execution in superjson
IDs: CVE-2022-23631, GHSA-5888-ffcr-r425
Record: https://patchnext.com/advisories/cve-2022-23631 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: blitz 0.45.3; superjson 1.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm blitz: affected < 0.45.3; fixed in 0.45.3
- npm superjson: affected < 1.8.1; fixed in 1.8.1

## Suggested inspection (read-only)
- `npm ls blitz --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls superjson --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on blitz, superjson.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5888-ffcr-r425 (OSV record GHSA-5888-ffcr-r425 lists affected ranges: npm superjson >=0 =0 <0.45.3 (fixed))
- Verified: https://github.com/advisories/GHSA-5888-ffcr-r425 (GitHub-reviewed advisory GHSA-5888-ffcr-r425 lists affected ranges: npm superjson >=0 =0 <0.45.3)

Commands are suggestions: review each one before running it.

Loading voting…