Low, CVSS 3.3npmAmendedPublished
Imperative CLI vulnerable to Command Injection
CVE-2021-4326 · GHSA-6q8m-42qq-64r7
- Affected
- npm @zowe/imperative >= 5.0.0, < 5.7.1; < 4.18.10
- Fixed in
- 5.7.14.18.10· Vendor fix available
- Issue
- A vulnerability in Imperative framework which allows already-privileged local actors to execute arbitrary shell commands via plugin install/update commands, or maliciously formed environment variables. Impacts Zowe CLI.
Recommended action: Upgrade to 5.7.1 or 4.18.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.