Imperative CLI vulnerable to Command Injection
CVE-2021-4326GHSA-6q8m-42qq-64r7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@zowe/imperative 5.7.1, 4.18.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @zowe/imperative
- Affected
- >= 5.0.0, < 5.7.1< 4.18.10
- Fixed in
- 5.7.1, 4.18.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6q8m-42qq-64r7 lists affected ranges: npm @zowe/imperative >=5.0.0 =0 <4.18.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6q8m-42qq-64r7 lists affected ranges: npm @zowe/imperative >=5.0.0 =0 <4.18.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2021-4326: 0.26% estimated exploitation activity in the next 30 days; percentile 17.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in Imperative framework which allows already-privileged local actors to execute arbitrary shell commands via plugin install/update commands, or maliciously formed environment variables. Impacts Zowe CLI.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6q8m-42qq-64r7
- Revision 1 · created ·
Published from osv record GHSA-6q8m-42qq-64r7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-4326 Advisory: Imperative CLI vulnerable to Command Injection IDs: CVE-2021-4326, GHSA-6q8m-42qq-64r7 Record: https://patchnext.com/advisories/cve-2021-4326 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @zowe/imperative 5.7.1, 4.18.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @zowe/imperative: affected >= 5.0.0, < 5.7.1; < 4.18.10; fixed in 5.7.1, 4.18.10 ## Suggested inspection (read-only) - `npm ls @zowe/imperative --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @zowe/imperative. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6q8m-42qq-64r7 (OSV record GHSA-6q8m-42qq-64r7 lists affected ranges: npm @zowe/imperative >=5.0.0 =0 <4.18.10 (fixed)) - Verified: https://github.com/advisories/GHSA-6q8m-42qq-64r7 (GitHub-reviewed advisory GHSA-6q8m-42qq-64r7 lists affected ranges: npm @zowe/imperative >=5.0.0 =0 <4.18.10) Commands are suggestions: review each one before running it.
Loading voting…