UnratednpmAmendedPublished
x402 SDK Security Advisory
GHSA-qr2g-p6q7-w82m
- Affected
- npm @x402/svm < 2.6.0
- Fixed in
- 2.6.0· Vendor fix available
- Issue
- Impact A security vulnerability exists in outdated versions of the x402 SDK. This vulnerability does not affect users' private keys, smart contracts, or funds. The issue impacts resource servers accepting payments on Solana when the facilitator is running a vulnerable version of the x402 SDK. Who Should Take Action Facilitators that process payments on Solana must upgrade the x402 SDK to the patched versions listed below. Clients are not required to upgrade. Resource servers are not required to upgrade unless they operate their own facilitator (self-facilitate). Patches Please update to the following package versions: Npm: @x402/svm = 2.6.0 Pypi: x402 = 2.3.0 Go: x402 = 2.5.0
Recommended action: Upgrade to 2.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.