x402 SDK Security Advisory
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (x402 2.3.0; github.com/coinbase/x402/go 2.5.0; @x402/svm 2.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI x402
- Affected
- < 2.3.0
- Fixed in
- 2.3.0
Go github.com/coinbase/x402/go
- Affected
- < 2.5.0
- Fixed in
- 2.5.0
npm @x402/svm
- Affected
- < 2.6.0
- Fixed in
- 2.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qr2g-p6q7-w82m lists affected ranges: npm @x402/svm >=0 =0 =0 <2.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qr2g-p6q7-w82m lists affected ranges: npm @x402/svm >=0 =0 =0 <2.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A security vulnerability exists in outdated versions of the x402 SDK. This vulnerability does not affect users' private keys, smart contracts, or funds. The issue impacts resource servers accepting payments on Solana when the facilitator is running a vulnerable version of the x402 SDK. Who Should Take Action Facilitators that process payments on Solana must upgrade the x402 SDK to the patched versions listed below. Clients are not required to upgrade. Resource servers are not required to upgrade unless they operate their own facilitator (self-facilitate). Patches Please update to the following package versions: Npm: @x402/svm = 2.6.0 Pypi: x402 = 2.3.0 Go: x402 = 2.5.0
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qr2g-p6q7-w82m
- Revision 1 · created ·
Published from osv record GHSA-qr2g-p6q7-w82m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-qr2g-p6q7-w82m Advisory: x402 SDK Security Advisory IDs: GHSA-qr2g-p6q7-w82m Record: https://patchnext.com/advisories/ghsa-qr2g-p6q7-w82m (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: x402 2.3.0; github.com/coinbase/x402/go 2.5.0; @x402/svm 2.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI x402: affected < 2.3.0; fixed in 2.3.0 - Go github.com/coinbase/x402/go: affected < 2.5.0; fixed in 2.5.0 - npm @x402/svm: affected < 2.6.0; fixed in 2.6.0 ## Suggested inspection (read-only) - `python -m pip show x402`: prints the installed version. Run with the environment that serves production active. - Go github.com/coinbase/x402/go: check the installed version with your package manager. - `npm ls @x402/svm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on x402, github.com/coinbase/x402/go, @x402/svm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qr2g-p6q7-w82m (OSV record GHSA-qr2g-p6q7-w82m lists affected ranges: npm @x402/svm >=0 =0 =0 <2.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-qr2g-p6q7-w82m (GitHub-reviewed advisory GHSA-qr2g-p6q7-w82m lists affected ranges: npm @x402/svm >=0 =0 =0 <2.5.0) Commands are suggestions: review each one before running it.
Loading voting…