Low, CVSS 2.1npmAmendedPublished
DesktopCommanderMCP is vulnerable to Uncontrolled Resource Consumption
CVE-2026-10691 · GHSA-r87g-78mx-3wg4
- Affected
- npm @wonderwhy-er/desktop-commander < 0.2.39
- Fixed in
- 0.2.39· Vendor fix available
- Issue
- A security flaw has been discovered in wonderwhy-er DesktopCommanderMCP up to 0.2.38. This impacts an unknown function of the file src/search-manager.ts of the component startsearch. Performing a manipulation of the argument SearchResult[] results in inefficient regular expression complexity. It is possible to initiate the attack remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 0.2.39 will fix this issue. The patch is named 4ce845f8749b6a159b57b38dcc3357f7222a8078. It is suggested to upgrade the affected component.
Recommended action: Upgrade to 0.2.39 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.