Skip to content

← Actionable
Low, CVSS 2.1amended

DesktopCommanderMCP is vulnerable to Uncontrolled Resource Consumption

CVE-2026-10691GHSA-r87g-78mx-3wg4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@wonderwhy-er/desktop-commander 0.2.39), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-10691: 0.35% estimated exploitation activity in the next 30 days; percentile 29.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A security flaw has been discovered in wonderwhy-er DesktopCommanderMCP up to 0.2.38. This impacts an unknown function of the file src/search-manager.ts of the component startsearch. Performing a manipulation of the argument SearchResult[] results in inefficient regular expression complexity. It is possible to initiate the attack remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 0.2.39 will fix this issue. The patch is named 4ce845f8749b6a159b57b38dcc3357f7222a8078. It is suggested to upgrade the affected component.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r87g-78mx-3wg4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r87g-78mx-3wg4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-10691

Advisory: DesktopCommanderMCP is vulnerable to Uncontrolled Resource Consumption
IDs: CVE-2026-10691, GHSA-r87g-78mx-3wg4
Record: https://patchnext.com/advisories/cve-2026-10691 (revision 3, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @wonderwhy-er/desktop-commander 0.2.39. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @wonderwhy-er/desktop-commander: affected < 0.2.39; fixed in 0.2.39

## Suggested inspection (read-only)
- `npm ls @wonderwhy-er/desktop-commander --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @wonderwhy-er/desktop-commander.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r87g-78mx-3wg4 (OSV record GHSA-r87g-78mx-3wg4 lists affected ranges: npm @wonderwhy-er/desktop-commander >=0 <0.2.39 (fixed))
- Verified: https://github.com/advisories/GHSA-r87g-78mx-3wg4 (GitHub-reviewed advisory GHSA-r87g-78mx-3wg4 lists affected ranges: npm @wonderwhy-er/desktop-commander >=0 <0.2.39)

Commands are suggestions: review each one before running it.

Loading voting…