Skip to content

← Public intelligence

npm package

@uppy/companion

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Incorrect Authorization in @uppy/companion

    CVE-2022-0528 · GHSA-q24h-5rq3-63j9

    Affected
    • npm @uppy/companion < 3.3.1
    Fixed in
    3.3.1· Vendor fix available
    Issue
    @uppy/companion prior to version 3.3.1 is vulnerable to incorrect authorization. A user with URL upload access could enumerate internal companion server networks, send local webservers files to the destination server, and finally download them If each of these files had a guessable and regular name.

    Recommended action: Upgrade to 3.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.2npmAmendedPublished

    uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF)

    CVE-2022-0086 · GHSA-x8rq-rc7x-5fg5

    Affected
    • npm @uppy/companion < 3.1.5
    Fixed in
    3.1.5· Vendor fix available
    Issue
    uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF) via IPv4-mapped IPv6 addresses.

    Recommended action: Upgrade to 3.1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. UnratednpmAmendedPublished

    Server-Side Request Forgery in @uppy/companion

    CVE-2020-8135 · GHSA-mm7r-265w-jv6f

    Affected
    • npm @uppy/companion < 1.9.3
    Fixed in
    1.9.3· Vendor fix available
    Issue
    Versions of @uppy/companion prior to 1.9.3 are vulnerable to Server-Side Request Forgery (SSRF). The get route passes the user-controlled variable req.body.url to a GET request without sanitizing the value. This allows attackers to inject arbitrary URLs and make GET requests on behalf of the server. Recommendation Upgrade to version 1.9.3 or later.

    Recommended action: Upgrade to 1.9.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 7.5npmAmendedPublished

    Server-Side Request Forgery in @uppy/companion

    CVE-2020-8205 · GHSA-9m4x-8w29-r78g

    Affected
    • npm @uppy/companion < 1.13.2; >= 2.0.0-alpha.0, <= 2.0.0-alpha.4
    Fixed in
    2.0.0-alpha.51.13.2· Vendor fix available
    Issue
    The @uppy/companion npm package before versions 1.13.2 and 2.0.0-alpha.5 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external networks or otherwise interact with internal systems.

    Recommended action: Upgrade to 2.0.0-alpha.5 (pre-release) or 1.13.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →