uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF)
CVE-2022-0086GHSA-x8rq-rc7x-5fg5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@uppy/companion 3.1.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @uppy/companion
- Affected
- < 3.1.5
- Fixed in
- 3.1.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x8rq-rc7x-5fg5 lists affected ranges: npm @uppy/companion >=0 <3.1.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x8rq-rc7x-5fg5 lists affected ranges: npm @uppy/companion >=0 <3.1.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2022-0086: 1.25% estimated exploitation activity in the next 30 days; percentile 69.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF) via IPv4-mapped IPv6 addresses.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x8rq-rc7x-5fg5
- Revision 1 · created ·
Published from osv record GHSA-x8rq-rc7x-5fg5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-0086 Advisory: uppy's companion module is vulnerable to Server-Side Request Forgery (SSRF) IDs: CVE-2022-0086, GHSA-x8rq-rc7x-5fg5 Record: https://patchnext.com/advisories/cve-2022-0086 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @uppy/companion 3.1.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @uppy/companion: affected < 3.1.5; fixed in 3.1.5 ## Suggested inspection (read-only) - `npm ls @uppy/companion --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @uppy/companion. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x8rq-rc7x-5fg5 (OSV record GHSA-x8rq-rc7x-5fg5 lists affected ranges: npm @uppy/companion >=0 <3.1.5 (fixed)) - Verified: https://github.com/advisories/GHSA-x8rq-rc7x-5fg5 (GitHub-reviewed advisory GHSA-x8rq-rc7x-5fg5 lists affected ranges: npm @uppy/companion >=0 <3.1.5) Commands are suggestions: review each one before running it.
Loading voting…