Low, CVSS 1.9npmAmendedPublished
@tootallnate/once vulnerable to Incorrect Control Flow Scoping
CVE-2026-3449 · GHSA-vpq2-c234-7xj6
- Affected
- npm @tootallnate/once >= 3.0.0, < 3.0.1; < 2.0.1
- Fixed in
- 2.0.13.0.1· Vendor fix available
- Issue
- Versions of the package @tootallnate/once before 3.0.1 are vulnerable to Incorrect Control Flow Scoping in promise resolving when AbortSignal option is used. The Promise remains in a permanently pending state after the signal is aborted, causing any await or .then() usage to hang indefinitely. This can cause a control-flow leak that can lead to stalled requests, blocked workers, or degraded application availability.
Recommended action: Upgrade to 3.0.1 or 2.0.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.