@tootallnate/once vulnerable to Incorrect Control Flow Scoping
CVE-2026-3449GHSA-vpq2-c234-7xj6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@tootallnate/once 3.0.1, 2.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 3.0.0, < 3.0.1< 2.0.1
- Fixed in
- 2.0.1, 3.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vpq2-c234-7xj6 lists affected ranges: npm @tootallnate/once >=3.0.0 =0 <2.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vpq2-c234-7xj6 lists affected ranges: npm @tootallnate/once >=3.0.0 =0 <2.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-3449: 0.13% estimated exploitation activity in the next 30 days; percentile 2.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package @tootallnate/once before 3.0.1 are vulnerable to Incorrect Control Flow Scoping in promise resolving when AbortSignal option is used. The Promise remains in a permanently pending state after the signal is aborted, causing any await or .then() usage to hang indefinitely. This can cause a control-flow leak that can lead to stalled requests, blocked workers, or degraded application availability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vpq2-c234-7xj6
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vpq2-c234-7xj6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-3449 Advisory: @tootallnate/once vulnerable to Incorrect Control Flow Scoping IDs: CVE-2026-3449, GHSA-vpq2-c234-7xj6 Record: https://patchnext.com/advisories/cve-2026-3449 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @tootallnate/once 3.0.1, 2.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @tootallnate/once: affected >= 3.0.0, < 3.0.1; < 2.0.1; fixed in 2.0.1, 3.0.1 ## Suggested inspection (read-only) - `npm ls @tootallnate/once --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @tootallnate/once. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vpq2-c234-7xj6 (OSV record GHSA-vpq2-c234-7xj6 lists affected ranges: npm @tootallnate/once >=3.0.0 =0 <2.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-vpq2-c234-7xj6 (GitHub-reviewed advisory GHSA-vpq2-c234-7xj6 lists affected ranges: npm @tootallnate/once >=3.0.0 =0 <2.0.1) Commands are suggestions: review each one before running it.
Loading voting…