Critical, CVSS 9.6npmPublished
Cross-site Scripting (XSS) in Eclipse Theia
CVE-2020-27224 · GHSA-gcm9-cc3r-c6vj
- Affected
- npm @theia/preview < 1.3.0
- Fixed in
- 1.3.0· Vendor fix available
- Issue
- In Eclipse Theia versions up to and including 1.2.0, the Markdown Preview (@theia/preview), can be exploited to execute arbitrary code.
Recommended action: Upgrade to 1.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.