Cross-site Scripting (XSS) in Eclipse Theia
CVE-2020-27224GHSA-gcm9-cc3r-c6vj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@theia/preview 1.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @theia/preview
- Affected
- < 1.3.0
- Fixed in
- 1.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gcm9-cc3r-c6vj lists affected ranges: npm @theia/preview >=0 <1.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2020-27224: 2.59% estimated exploitation activity in the next 30 days; percentile 85.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Eclipse Theia versions up to and including 1.2.0, the Markdown Preview (@theia/preview), can be exploited to execute arbitrary code.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GHSA-gcm9-cc3r-c6vj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-27224 Advisory: Cross-site Scripting (XSS) in Eclipse Theia IDs: CVE-2020-27224, GHSA-gcm9-cc3r-c6vj Record: https://patchnext.com/advisories/cve-2020-27224 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @theia/preview 1.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @theia/preview: affected < 1.3.0; fixed in 1.3.0 ## Suggested inspection (read-only) - `npm ls @theia/preview --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @theia/preview. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gcm9-cc3r-c6vj (OSV record GHSA-gcm9-cc3r-c6vj lists affected ranges: npm @theia/preview >=0 <1.3.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…