Skip to content

← Public intelligence

npm package

@supabase/auth-js

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.7npmAmendedPublished

    auth-js Vulnerable to Insecure Path Routing from Malformed User Input

    CVE-2025-48370 · GHSA-8r88-6cj9-9fh5

    Affected
    • npm @supabase/auth-js <= 2.69.1
    Fixed in
    2.70.0· Vendor fix available
    Issue
    Impact The library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. Patches Strict value checks have been added to all affected functions. These functions now require that the userId and factorId parameters MUST be valid UUID (v4). Patched version: = 2.69.1 Workarounds Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. It is recommended that users of the auth-js library always follow security best practice and validate all inputs, before passing these to other functions or libraries. References https://github.com/supabase/auth-js/pull/1063

    Recommended action: Upgrade to 2.70.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →