Skip to content

← Actionable
Low, CVSS 2.7amended

auth-js Vulnerable to Insecure Path Routing from Malformed User Input

CVE-2025-48370GHSA-8r88-6cj9-9fh5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@supabase/auth-js 2.70.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2025-48370: 0.90% estimated exploitation activity in the next 30 days; percentile 59.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. Patches Strict value checks have been added to all affected functions. These functions now require that the userId and factorId parameters MUST be valid UUID (v4). Patched version: = 2.69.1 Workarounds Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. It is recommended that users of the auth-js library always follow security best practice and validate all inputs, before passing these to other functions or libraries. References https://github.com/supabase/auth-js/pull/1063

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8r88-6cj9-9fh5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8r88-6cj9-9fh5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-48370

Advisory: auth-js Vulnerable to Insecure Path Routing from Malformed User Input
IDs: CVE-2025-48370, GHSA-8r88-6cj9-9fh5
Record: https://patchnext.com/advisories/cve-2025-48370 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @supabase/auth-js 2.70.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @supabase/auth-js: affected <= 2.69.1; fixed in 2.70.0

## Suggested inspection (read-only)
- `npm ls @supabase/auth-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @supabase/auth-js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8r88-6cj9-9fh5 (OSV record GHSA-8r88-6cj9-9fh5 lists affected ranges: npm @supabase/auth-js >=0 <2.70.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8r88-6cj9-9fh5 (GitHub-reviewed advisory GHSA-8r88-6cj9-9fh5 lists affected ranges: npm @supabase/auth-js >=0 <=2.69.1)

Commands are suggestions: review each one before running it.

Loading voting…