Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
Impact What kind of vulnerability is it? Who is impacted? Anyone who might have used Soketi with the cluster driver (or through PM2). Patches Has the problem been patched? What versions should users upgrade to? Get the latest version of Soketi. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? None. It's advised to upgrade to the latest version. References Are there any links users can visit to find out more? - https://github.com/advisories/GHSA-cchq-frgv-rjh5 - https://github.com/patriksimek/vm2/issues/533 - https://github.com/Unitech/pm2/issues/5643
Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Impact What kind of vulnerability is it? Who is impacted? colors package caused zalgo-like output (see https://github.com/soketi/soketi/issues/276, https://github.com/Marak/colors.js/issues/289), breaking the servers. Only NPM users that recently upgraded or installed the NPM package are affected. Docker users seem to not be affected as the dependencies were bundled at the time of the build, which were tested. Patches Has the problem been patched? What versions should users upgrade to? Latest patch. 0.26.1 to be exact at the time of writing. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? You cannot get around this as it's related to dependencies. References Are there any links users can visit to find out more? - https://github.com/Marak/colors.js/issues/289 For more information If you have any questions or comments about this advisory: Open an issue in the issues board Email us at alex@renoki.org
Recommended action: Upgrade to 0.26.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Impact What kind of vulnerability is it? Who is impacted? There was a wrong behavior when reading POST requests, making the server crash if it couldn't read the body. In case a POST request was sent to any endpoint of the server with an empty body, even unauthenticated with the Pusher Protocol, it would simply just crash the server for trying to send a response after the request closed. All users that run the server are affected by it and it's highly recommended to upgrade to the latest patch. Patches Has the problem been patched? What versions should users upgrade to? Updating to at least 0.24.1 or the latest version. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? No. Upgrading is the only solution. References Are there any links users can visit to find out more? https://github.com/soketi/soketi/releases/tag/0.24.1 For more information If you have any questions or comments about this advisory: Open an issue in the issues board Email us…
Recommended action: Upgrade to 0.24.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.