Skip to content

← Actionable
Critical, CVSS 9.8amended

Soketi was exposed to Sandbox Escape vulnerability via vm2

GHSA-g6w6-h933-4rc5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@soketi/soketi 1.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? Anyone who might have used Soketi with the cluster driver (or through PM2). Patches Has the problem been patched? What versions should users upgrade to? Get the latest version of Soketi. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? None. It's advised to upgrade to the latest version. References Are there any links users can visit to find out more? - https://github.com/advisories/GHSA-cchq-frgv-rjh5 - https://github.com/patriksimek/vm2/issues/533 - https://github.com/Unitech/pm2/issues/5643

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g6w6-h933-4rc5

  2. Revision 1 · created ·

    Published from osv record GHSA-g6w6-h933-4rc5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-g6w6-h933-4rc5

Advisory: Soketi was exposed to Sandbox Escape vulnerability via vm2
IDs: GHSA-g6w6-h933-4rc5
Record: https://patchnext.com/advisories/ghsa-g6w6-h933-4rc5 (revision 2, source checked 26 Oct 2026, 12:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @soketi/soketi 1.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @soketi/soketi: affected < 1.6.0; fixed in 1.6.0

## Suggested inspection (read-only)
- `npm ls @soketi/soketi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @soketi/soketi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g6w6-h933-4rc5 (OSV record GHSA-g6w6-h933-4rc5 lists affected ranges: npm @soketi/soketi >=0 <1.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g6w6-h933-4rc5 (GitHub-reviewed advisory GHSA-g6w6-h933-4rc5 lists affected ranges: npm @soketi/soketi >=0 <1.6.0)

Commands are suggestions: review each one before running it.

Loading voting…