High, CVSS 8.6npmAmendedPublished
Payload: Improper access control for MCP API keys
CVE-2026-105806 · GHSA-2q76-m6w6-qgc6
- Affected
- npm @payloadcms/plugin-mcp >= 3.61.0, < 3.88.0
- Fixed in
- 3.88.0· Vendor fix available
- Issue
- Impact Under certain conditions, an authenticated user could manage MCP API keys outside their intended account allowing an attacker to escalate privileges through account takeover. Applications that do not use @payloadcms/plugin-mcp are not affected. Patches Users should upgrade to @payloadcms/plugin-mcp version 3.88.0 or later. Workarounds Upgrading is recommended. Until then, disable the MCP plugin or restrict MCP API-key management to trusted users.
Recommended action: Upgrade to 3.88.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.