Skip to content

← Actionable
High, CVSS 8.6amended

Payload: Improper access control for MCP API keys

CVE-2026-105806GHSA-2q76-m6w6-qgc6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@payloadcms/plugin-mcp 3.88.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-105806: 0.25% estimated exploitation activity in the next 30 days; percentile 16.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Under certain conditions, an authenticated user could manage MCP API keys outside their intended account allowing an attacker to escalate privileges through account takeover. Applications that do not use @payloadcms/plugin-mcp are not affected. Patches Users should upgrade to @payloadcms/plugin-mcp version 3.88.0 or later. Workarounds Upgrading is recommended. Until then, disable the MCP plugin or restrict MCP API-key management to trusted users.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-2q76-m6w6-qgc6

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-2q76-m6w6-qgc6

  4. Revision 1 · created ·

    Published from ghsa record GHSA-2q76-m6w6-qgc6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-105806

Advisory: Payload: Improper access control for MCP API keys
IDs: CVE-2026-105806, GHSA-2q76-m6w6-qgc6
Record: https://patchnext.com/advisories/cve-2026-105806 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @payloadcms/plugin-mcp 3.88.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @payloadcms/plugin-mcp: affected >= 3.61.0, < 3.88.0; fixed in 3.88.0

## Suggested inspection (read-only)
- `npm ls @payloadcms/plugin-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @payloadcms/plugin-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2q76-m6w6-qgc6 (GitHub-reviewed advisory GHSA-2q76-m6w6-qgc6 lists affected ranges: npm @payloadcms/plugin-mcp >=3.61.0 <3.88.0)
- Verified: https://osv.dev/vulnerability/GHSA-2q76-m6w6-qgc6 (OSV record GHSA-2q76-m6w6-qgc6 lists affected ranges: npm @payloadcms/plugin-mcp >=3.61.0 <3.88.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…