Skip to content

← Public intelligence

npm package

@payloadcms/db-mongodb

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1npmAmendedPublished

    Payload: Field-level write access bypass in Payload on MongoDB

    CVE-2026-106100 · GHSA-4ww4-68q3-h7g5

    Affected
    • npm @payloadcms/db-mongodb < 3.87.0; >= 4.0.0-canary.0, < 4.0.0-canary.20
    Fixed in
    4.0.0-canary.203.87.0· Vendor fix available
    Issue
    Impact A vulnerability in field-level access control could allow an authenticated user to modify fields they are not permitted to change on documents they can otherwise update. You are affected if: Payload version < 3.87.0 (or a 4.0.0-canary release before 4.0.0-canary.20) using the MongoDB adapter (@payloadcms/db-mongodb) with any collection that relies on field-level access control to restrict writes under certain conditions. Relational adapters (Postgres, SQLite) are not affected. Patches Handling of incoming field data has been hardened so field-level access control is enforced consistently. Users should upgrade to 3.87.0 (or 4.0.0-canary.20 on the 4.x line) or later. Workarounds There is no complete workaround. Upgrading to 3.87.0 (or 4.0.0-canary.20 on the 4.x line) is recommended.

    Recommended action: Upgrade to 4.0.0-canary.20 (pre-release) or 3.87.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →