Payload: Field-level write access bypass in Payload on MongoDB
CVE-2026-106100GHSA-4ww4-68q3-h7g5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@payloadcms/db-mongodb 4.0.0-canary.20, 3.87.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.87.0>= 4.0.0-canary.0, < 4.0.0-canary.20
- Fixed in
- 4.0.0-canary.20, 3.87.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4ww4-68q3-h7g5 lists affected ranges: npm @payloadcms/db-mongodb >=0 =4.0.0-canary.0 <4.0.0-canary.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4ww4-68q3-h7g5 lists affected ranges: npm @payloadcms/db-mongodb >=0 =4.0.0-canary.0 <4.0.0-canary.20 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
- EPSS
- CVE-2026-106100: 0.22% estimated exploitation activity in the next 30 days; percentile 12.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability in field-level access control could allow an authenticated user to modify fields they are not permitted to change on documents they can otherwise update. You are affected if: Payload version < 3.87.0 (or a 4.0.0-canary release before 4.0.0-canary.20) using the MongoDB adapter (@payloadcms/db-mongodb) with any collection that relies on field-level access control to restrict writes under certain conditions. Relational adapters (Postgres, SQLite) are not affected. Patches Handling of incoming field data has been hardened so field-level access control is enforced consistently. Users should upgrade to 3.87.0 (or 4.0.0-canary.20 on the 4.x line) or later. Workarounds There is no complete workaround. Upgrading to 3.87.0 (or 4.0.0-canary.20 on the 4.x line) is recommended.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4ww4-68q3-h7g5
- Revision 2 · amended ·
Amended from osv record GHSA-4ww4-68q3-h7g5
- Revision 1 · created ·
Published from ghsa record GHSA-4ww4-68q3-h7g5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-106100 Advisory: Payload: Field-level write access bypass in Payload on MongoDB IDs: CVE-2026-106100, GHSA-4ww4-68q3-h7g5 Record: https://patchnext.com/advisories/cve-2026-106100 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @payloadcms/db-mongodb 4.0.0-canary.20, 3.87.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @payloadcms/db-mongodb: affected < 3.87.0; >= 4.0.0-canary.0, < 4.0.0-canary.20; fixed in 4.0.0-canary.20, 3.87.0 ## Suggested inspection (read-only) - `npm ls @payloadcms/db-mongodb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @payloadcms/db-mongodb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4ww4-68q3-h7g5 (GitHub-reviewed advisory GHSA-4ww4-68q3-h7g5 lists affected ranges: npm @payloadcms/db-mongodb >=0 =4.0.0-canary.0 <4.0.0-canary.20) - Verified: https://osv.dev/vulnerability/GHSA-4ww4-68q3-h7g5 (OSV record GHSA-4ww4-68q3-h7g5 lists affected ranges: npm @payloadcms/db-mongodb >=0 =4.0.0-canary.0 <4.0.0-canary.20 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…