Skip to content

← Public intelligence

npm package

@node-saml/node-saml

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3npmAmendedPublished

    @node-saml/node-saml's validatePostRequestAsync does not include checkTimestampsValidityError

    CVE-2023-40178 · GHSA-vx8m-6fhw-pccw

    Affected
    • npm @node-saml/node-saml < 4.0.5
    Fixed in
    4.0.5· Vendor fix available
    Issue
    The lack of checking of current timestamp allows a LogoutRequest XML to be reused multiple times even when the current time is past the NotOnOrAfter. Details It was noticed that in the validatePostRequestAsync() flow in saml.js, the current timestamp is never checked. This could present a vulnerability where a user who has an XML LogoutRequest could validated it if the IssueInstance and the NotOnOrAfter are valid along with valid credentials (signature, certificate etc.). PoC I was able to validate a sample valid LogoutRequest XML multiple times through postman by sending it to my endpoint regardless if the current present time was past the NotOnOrAfter time. After some further testing, it seems that only the IssueInstance is checked against NotOnOrAfter. Not sure if this was the intended behaviour but I believe having a never expiring valid LogoutRequest could be dangerous. Impact This could impact the user where they would be logged out from an expired LogoutRequest. In…

    Recommended action: Upgrade to 4.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.1npmAmendedPublished

    Signature bypass via multiple root elements

    CVE-2022-39299 · GHSA-m974-647v-whv7

    Affected
    • npm @node-saml/node-saml < 4.0.0-beta.5
    Fixed in
    4.0.0-beta.5· Vendor fix available
    Issue
    Impact A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Patches Users should upgrade to passport-saml 3.2.2 or newer. The issue was also present in the beta releases of node-saml before v4.0.0-beta.5. Workarounds Disable SAML authentication. References Are there any links users can visit to find out more? For more information If you have any questions or comments about this advisory: Open a discussion in the node-saml repo Credits Felix Wilhelm of Google Project Zero

    Recommended action: Upgrade to 4.0.0-beta.5 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →