Skip to content

← Actionable
High, CVSS 8.1amended

Signature bypass via multiple root elements

CVE-2022-39299GHSA-m974-647v-whv7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@node-saml/node-saml 4.0.0-beta.5; node-saml 4.0.0-beta.5; passport-saml 3.2.2; @node-saml/passport-saml 4.0.0-beta.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-39299: 4.49% estimated exploitation activity in the next 30 days; percentile 91.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Patches Users should upgrade to passport-saml 3.2.2 or newer. The issue was also present in the beta releases of node-saml before v4.0.0-beta.5. Workarounds Disable SAML authentication. References Are there any links users can visit to find out more? For more information If you have any questions or comments about this advisory: Open a discussion in the node-saml repo Credits Felix Wilhelm of Google Project Zero

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m974-647v-whv7

  2. Revision 1 · created ·

    Published from osv record GHSA-m974-647v-whv7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-39299

Advisory: Signature bypass via multiple root elements
IDs: CVE-2022-39299, GHSA-m974-647v-whv7
Record: https://patchnext.com/advisories/cve-2022-39299 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @node-saml/node-saml 4.0.0-beta.5; node-saml 4.0.0-beta.5; passport-saml 3.2.2; @node-saml/passport-saml 4.0.0-beta.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @node-saml/node-saml: affected < 4.0.0-beta.5; fixed in 4.0.0-beta.5
- npm node-saml: affected < 4.0.0-beta.5; fixed in 4.0.0-beta.5
- npm passport-saml: affected < 3.2.2; fixed in 3.2.2
- npm @node-saml/passport-saml: affected < 4.0.0-beta.3; fixed in 4.0.0-beta.3

## Suggested inspection (read-only)
- `npm ls @node-saml/node-saml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls node-saml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls passport-saml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @node-saml/passport-saml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @node-saml/node-saml, node-saml, passport-saml, @node-saml/passport-saml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m974-647v-whv7 (OSV record GHSA-m974-647v-whv7 lists affected ranges: npm passport-saml >=0 =0 =0 =0 <4.0.0-beta.3 (fixed))
- Verified: https://github.com/advisories/GHSA-m974-647v-whv7 (GitHub-reviewed advisory GHSA-m974-647v-whv7 lists affected ranges: npm passport-saml >=0 =0 =0 =0 <4.0.0-beta.3)

Commands are suggestions: review each one before running it.

Loading voting…