Skip to content

← Public intelligence

npm package

@nocobase/plugin-backups

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.7npmPublished

    NocoBase backup restore schema name allows command injection

    CVE-2026-55410 · GHSA-p853-83gj-wjj3

    Affected
    • npm @nocobase/plugin-backups < 2.1.19
    Fixed in
    2.1.19· Vendor fix available
    Issue
    NocoBase @nocobase/plugin-backups 2.0.57 restores PostgreSQL backups by interpolating the backup metadata schema name into shell command strings that are executed with Node.js childprocess.exec(). A backup-management user who can restore an uploaded PostgreSQL backup with forced schema restore can place shell metacharacters in metadata.json under database.schema, causing arbitrary commands to execute as the NocoBase server process during restore. The vulnerable plugin is included in the default @nocobase/preset-nocobase package and is guarded by the backup-management ACL snippet (backups: / backup:). This is not unauthenticated; the attacker must have backup restore privileges or equivalent access to the restore API/CLI. Details Affected product evidence: - Ecosystem/package: npm package @nocobase/plugin-backups from packages/plugins/@nocobase/plugin-backups/package.json. - Tested vulnerable version: 2.0.57 (packages/plugins/@nocobase/plugin-backups/package.json:1-16). -…

    Recommended action: Upgrade to 2.1.19 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →