NocoBase backup restore schema name allows command injection
CVE-2026-55410GHSA-p853-83gj-wjj3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nocobase/plugin-backups 2.1.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.1.19
- Fixed in
- 2.1.19
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p853-83gj-wjj3 lists affected ranges: npm @nocobase/plugin-backups >=0 <2.1.19
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:H
- EPSS
- CVE-2026-55410: 0.72% estimated exploitation activity in the next 30 days; percentile 54.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary NocoBase @nocobase/plugin-backups 2.0.57 restores PostgreSQL backups by interpolating the backup metadata schema name into shell command strings that are executed with Node.js childprocess.exec(). A backup-management user who can restore an uploaded PostgreSQL backup with forced schema restore can place shell metacharacters in metadata.json under database.schema, causing arbitrary commands to execute as the NocoBase server process during restore. The vulnerable plugin is included in the default @nocobase/preset-nocobase package and is guarded by the backup-management ACL snippet (backups: / backup:). This is not unauthenticated; the attacker must have backup restore privileges or equivalent access to the restore API/CLI. Details Affected product evidence: - Ecosystem/package: npm package @nocobase/plugin-backups from packages/plugins/@nocobase/plugin-backups/package.json. - Tested vulnerable version: 2.0.57 (packages/plugins/@nocobase/plugin-backups/package.json:1-16). -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p853-83gj-wjj3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55410 Advisory: NocoBase backup restore schema name allows command injection IDs: CVE-2026-55410, GHSA-p853-83gj-wjj3 Record: https://patchnext.com/advisories/cve-2026-55410 (revision 1, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @nocobase/plugin-backups 2.1.19. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @nocobase/plugin-backups: affected < 2.1.19; fixed in 2.1.19 ## Suggested inspection (read-only) - `npm ls @nocobase/plugin-backups --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @nocobase/plugin-backups. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p853-83gj-wjj3 (GitHub-reviewed advisory GHSA-p853-83gj-wjj3 lists affected ranges: npm @nocobase/plugin-backups >=0 <2.1.19) Commands are suggestions: review each one before running it.
Loading voting…