Medium, CVSS 5.5npmAmendedPublished
nest allows a remote attacker to execute arbitrary code via the Content-Type header
CVE-2024-29409 · GHSA-cj7v-w2c7-cp7c
- Affected
- npm @nestjs/common >= 11.0.0-next.1, < 11.0.16; < 10.4.16
- Fixed in
- 11.0.1610.4.16· Vendor fix available
- Issue
- File Upload vulnerability in nestjs nest prior to v.11.0.16 allows a remote attacker to execute arbitrary code via the Content-Type header.
Recommended action: Upgrade to 11.0.16 or 10.4.16 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.