Skip to content

← Actionable
Medium, CVSS 5.5amended

nest allows a remote attacker to execute arbitrary code via the Content-Type header

CVE-2024-29409GHSA-cj7v-w2c7-cp7c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nestjs/common 11.0.16, 10.4.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @nestjs/common

    Affected
    >= 11.0.0-next.1, < 11.0.16< 10.4.16
    Fixed in
    11.0.16, 10.4.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2024-29409: 0.34% estimated exploitation activity in the next 30 days; percentile 26.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

File Upload vulnerability in nestjs nest prior to v.11.0.16 allows a remote attacker to execute arbitrary code via the Content-Type header.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cj7v-w2c7-cp7c

  2. Revision 1 · created ·

    Published from osv record GHSA-cj7v-w2c7-cp7c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-29409

Advisory: nest allows a remote attacker to execute arbitrary code via the Content-Type header
IDs: CVE-2024-29409, GHSA-cj7v-w2c7-cp7c
Record: https://patchnext.com/advisories/cve-2024-29409 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @nestjs/common 11.0.16, 10.4.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @nestjs/common: affected >= 11.0.0-next.1, < 11.0.16; < 10.4.16; fixed in 11.0.16, 10.4.16

## Suggested inspection (read-only)
- `npm ls @nestjs/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @nestjs/common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cj7v-w2c7-cp7c (OSV record GHSA-cj7v-w2c7-cp7c lists affected ranges: npm @nestjs/common >=11.0.0-next.1 =0 <10.4.16 (fixed))
- Verified: https://github.com/advisories/GHSA-cj7v-w2c7-cp7c (GitHub-reviewed advisory GHSA-cj7v-w2c7-cp7c lists affected ranges: npm @nestjs/common >=11.0.0-next.1 =0 <10.4.16)

Commands are suggestions: review each one before running it.

Loading voting…