High, CVSS 8.8npmAmendedPublished
N8N's Chat Trigger component is vulnerable to XSS
CVE-2025-56265 · GHSA-v2x8-97xq-8xrr
- Affected
- npm @n8n/n8n-nodes-langchain < 1.107.0
- Fixed in
- 1.107.0· Vendor fix available
- Issue
- An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3, v1.100.1, and v1.101.1 allows attackers to execute arbitrary code via uploading a crafted HTML file.
Recommended action: Upgrade to 1.107.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.