N8N's Chat Trigger component is vulnerable to XSS
CVE-2025-56265GHSA-v2x8-97xq-8xrr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@n8n/n8n-nodes-langchain 1.107.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.107.0
- Fixed in
- 1.107.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v2x8-97xq-8xrr lists affected ranges: npm @n8n/n8n-nodes-langchain >=0 <1.107.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v2x8-97xq-8xrr lists affected ranges: npm @n8n/n8n-nodes-langchain >=0 <1.107.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-56265: 0.61% estimated exploitation activity in the next 30 days; percentile 49.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3, v1.100.1, and v1.101.1 allows attackers to execute arbitrary code via uploading a crafted HTML file.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v2x8-97xq-8xrr
- Revision 1 · created ·
Published from osv record GHSA-v2x8-97xq-8xrr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-56265 Advisory: N8N's Chat Trigger component is vulnerable to XSS IDs: CVE-2025-56265, GHSA-v2x8-97xq-8xrr Record: https://patchnext.com/advisories/cve-2025-56265 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @n8n/n8n-nodes-langchain 1.107.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @n8n/n8n-nodes-langchain: affected < 1.107.0; fixed in 1.107.0 ## Suggested inspection (read-only) - `npm ls @n8n/n8n-nodes-langchain --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @n8n/n8n-nodes-langchain. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v2x8-97xq-8xrr (OSV record GHSA-v2x8-97xq-8xrr lists affected ranges: npm @n8n/n8n-nodes-langchain >=0 <1.107.0 (fixed)) - Verified: https://github.com/advisories/GHSA-v2x8-97xq-8xrr (GitHub-reviewed advisory GHSA-v2x8-97xq-8xrr lists affected ranges: npm @n8n/n8n-nodes-langchain >=0 <1.107.0) Commands are suggestions: review each one before running it.
Loading voting…