High, CVSS 7.6npmAmendedPublished
@mattkrick/sanitize-svg vulnerable to Cross-Site Scripting (XSS)
CVE-2023-22461 · GHSA-h857-2g56-468g
- Affected
- npm @mattkrick/sanitize-svg <= 0.3.1
- Fixed in
- 0.4.0· Vendor fix available
- Issue
- Impact The sanitize-svg package uses a deny-list-pattern to sanitize SVGs to prevent cross-site scripting (XSS). In doing so, literal <script-tags and on-event handlers were detected: There are more ways to embed JavaScript in XML files. Anchor Tag (requires user to click link): Foreign Object Tag (no user interaction required): As a result, downstream software that relies on sanitize-svg and expects resulting SVGs to be safe, may be vulnerable to XSS. We are aware of at least one downstream project for which this vulnerability had security implications. Patches This vulnerability was addressed in v0.4.0. Workarounds N/A
Recommended action: Upgrade to 0.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.