Skip to content

← Actionable
High, CVSS 7.6amended

@mattkrick/sanitize-svg vulnerable to Cross-Site Scripting (XSS)

CVE-2023-22461GHSA-h857-2g56-468g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@mattkrick/sanitize-svg 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
EPSS
  • CVE-2023-22461: 0.59% estimated exploitation activity in the next 30 days; percentile 48.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The sanitize-svg package uses a deny-list-pattern to sanitize SVGs to prevent cross-site scripting (XSS). In doing so, literal <script-tags and on-event handlers were detected: There are more ways to embed JavaScript in XML files. Anchor Tag (requires user to click link): Foreign Object Tag (no user interaction required): As a result, downstream software that relies on sanitize-svg and expects resulting SVGs to be safe, may be vulnerable to XSS. We are aware of at least one downstream project for which this vulnerability had security implications. Patches This vulnerability was addressed in v0.4.0. Workarounds N/A

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h857-2g56-468g

  2. Revision 1 · created ·

    Published from osv record GHSA-h857-2g56-468g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-22461

Advisory: @mattkrick/sanitize-svg vulnerable to Cross-Site Scripting (XSS)
IDs: CVE-2023-22461, GHSA-h857-2g56-468g
Record: https://patchnext.com/advisories/cve-2023-22461 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @mattkrick/sanitize-svg 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @mattkrick/sanitize-svg: affected <= 0.3.1; fixed in 0.4.0

## Suggested inspection (read-only)
- `npm ls @mattkrick/sanitize-svg --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @mattkrick/sanitize-svg.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h857-2g56-468g (OSV record GHSA-h857-2g56-468g lists affected ranges: npm @mattkrick/sanitize-svg >=0 <0.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-h857-2g56-468g (GitHub-reviewed advisory GHSA-h857-2g56-468g lists affected ranges: npm @mattkrick/sanitize-svg >=0 <=0.3.1)

Commands are suggestions: review each one before running it.

Loading voting…