Skip to content

← Public intelligence

npm package

@marp-team/marp-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3npmAmendedPublished

    Marp Core allows XSS by improper neutralization of HTML sanitization

    CVE-2024-56510 · GHSA-x52f-h5g4-8qv5

    Affected
    • npm @marp-team/marp-core >= 3.0.2, <= 3.9.0; >= 4.0.0, <= 4.0.0
    Fixed in
    4.0.13.9.1· Vendor fix available
    Issue
    Marp Core (@marp-team/marp-core) from v3.0.2 to v3.9.0 and v4.0.0, are vulnerable to cross-site scripting (XSS) due to improper neutralization of HTML sanitization. Impact Marp Core includes an HTML sanitizer with allowlist support. In the affected versions, the built-in allowlist is enabled by default. When the allowlist is active, if insufficient HTML comments are included, the sanitizer may fail to properly sanitize HTML content and lead cross-site scripting (XSS). Patches Marp Core v3.9.1 and v4.0.1 have been patched to fix that. Workarounds If you are unable to update the package immediately, disable all HTML tags by setting html: false option in the Marp class constructor. References - CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') - https://github.com/marp-team/marp-core/pull/282 - https://github.com/marp-team/marp-core/commit/61a1def244d1b6faa8e2c0be97ec0b68cab3ab49 Credits Thanks to @Ry0taK for finding out this vulnerability.

    Recommended action: Upgrade to 4.0.1 or 3.9.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →