Marp Core allows XSS by improper neutralization of HTML sanitization
CVE-2024-56510GHSA-x52f-h5g4-8qv5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@marp-team/marp-core 4.0.1, 3.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 3.0.2, <= 3.9.0>= 4.0.0, <= 4.0.0
- Fixed in
- 4.0.1, 3.9.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x52f-h5g4-8qv5 lists affected ranges: npm @marp-team/marp-core >=3.0.2 =4.0.0 <4.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x52f-h5g4-8qv5 lists affected ranges: npm @marp-team/marp-core >=3.0.2 =4.0.0 <=4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2024-56510: 0.32% estimated exploitation activity in the next 30 days; percentile 24.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Marp Core (@marp-team/marp-core) from v3.0.2 to v3.9.0 and v4.0.0, are vulnerable to cross-site scripting (XSS) due to improper neutralization of HTML sanitization. Impact Marp Core includes an HTML sanitizer with allowlist support. In the affected versions, the built-in allowlist is enabled by default. When the allowlist is active, if insufficient HTML comments are included, the sanitizer may fail to properly sanitize HTML content and lead cross-site scripting (XSS). Patches Marp Core v3.9.1 and v4.0.1 have been patched to fix that. Workarounds If you are unable to update the package immediately, disable all HTML tags by setting html: false option in the Marp class constructor. References - CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') - https://github.com/marp-team/marp-core/pull/282 - https://github.com/marp-team/marp-core/commit/61a1def244d1b6faa8e2c0be97ec0b68cab3ab49 Credits Thanks to @Ry0taK for finding out this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x52f-h5g4-8qv5
- Revision 1 · created ·
Published from osv record GHSA-x52f-h5g4-8qv5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-56510 Advisory: Marp Core allows XSS by improper neutralization of HTML sanitization IDs: CVE-2024-56510, GHSA-x52f-h5g4-8qv5 Record: https://patchnext.com/advisories/cve-2024-56510 (revision 2, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @marp-team/marp-core 4.0.1, 3.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @marp-team/marp-core: affected >= 3.0.2, <= 3.9.0; >= 4.0.0, <= 4.0.0; fixed in 4.0.1, 3.9.1 ## Suggested inspection (read-only) - `npm ls @marp-team/marp-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @marp-team/marp-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x52f-h5g4-8qv5 (OSV record GHSA-x52f-h5g4-8qv5 lists affected ranges: npm @marp-team/marp-core >=3.0.2 =4.0.0 <4.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-x52f-h5g4-8qv5 (GitHub-reviewed advisory GHSA-x52f-h5g4-8qv5 lists affected ranges: npm @marp-team/marp-core >=3.0.2 =4.0.0 <=4.0.0) Commands are suggestions: review each one before running it.
Loading voting…