Skip to content

← Public intelligence

npm package

@langchain/community

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.1npmAmendedPublished

    LangChain Community: redirect chaining can lead to SSRF bypass via RecursiveUrlLoader

    CVE-2026-27795 · GHSA-mphv-75cg-56wg

    Affected
    • npm @langchain/community <= 1.1.17
    Fixed in
    1.1.18· Vendor fix available
    Issue
    A redirect-based Server-Side Request Forgery (SSRF) bypass exists in RecursiveUrlLoader in @langchain/community. The loader validates the initial URL but allows the underlying fetch to follow redirects automatically, which permits a transition from a safe public URL to an internal or metadata endpoint without revalidation. This is a bypass of the SSRF protections introduced in 1.1.14 (CVE-2026-26019). Affected Component - Package: @langchain/community - Component: RecursiveUrlLoader - Configuration: preventOutside (default: true) is insufficient to prevent this bypass when redirects are followed automatically. Description RecursiveUrlLoader is a web crawler that recursively follows links from a starting URL. The existing SSRF mitigation validates the initial URL before fetching, but it does not re-validate when the request follows redirects. Because fetch follows redirects by default, an attacker can supply a public URL that passes validation and then redirects to a private…

    Recommended action: Upgrade to 1.1.18 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 4.1npmAmendedPublished

    @langchain/community affected by SSRF Bypass in RecursiveUrlLoader via insufficient URL origin validation

    CVE-2026-26019 · GHSA-gf3v-fwqg-4vh7

    Affected
    • npm @langchain/community <= 1.1.13
    Fixed in
    1.1.14· Vendor fix available
    Issue
    The RecursiveUrlLoader class in @langchain/community is a web crawler that recursively follows links from a starting URL. Its preventOutside option (enabled by default) is intended to restrict crawling to the same site as the base URL. The implementation used String.startsWith() to compare URLs, which does not perform semantic URL validation. An attacker who controls content on a crawled page could include links to domains that share a string prefix with the target (e.g., https://example.com.attacker.com passes a startsWith check against https://example.com), causing the crawler to follow links to attacker-controlled or internal infrastructure. Additionally, the crawler performed no validation against private or reserved IP addresses. A crawled page could include links targeting cloud metadata services (169.254.169.254), localhost, or RFC 1918 addresses, and the crawler would fetch them without restriction. Impact An attacker who can influence the content of a page being…

    Recommended action: Upgrade to 1.1.14 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Low, CVSS 2.1npmAmendedPublished

    @langchain/community SQL Injection vulnerability

    CVE-2024-7042 · GHSA-6m59-8fmv-m5f9

    Affected
    • npm @langchain/community < 0.3.3
    Fixed in
    0.3.3· Vendor fix available
    Issue
    A vulnerability in the GraphCypherQAChain class of langchain-ai/langchainjs versions 0.2.5 and all versions with this class allows for prompt injection, leading to SQL injection. This vulnerability permits unauthorized data manipulation, data exfiltration, denial of service (DoS) by deleting all data, breaches in multi-tenant security environments, and data integrity issues. Attackers can create, update, or delete nodes and relationships without proper authorization, extract sensitive data, disrupt services, access data across different tenants, and compromise the integrity of the database.

    Recommended action: Upgrade to 0.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →