Skip to content

← Actionable
Medium, CVSS 4.1amended

@langchain/community affected by SSRF Bypass in RecursiveUrlLoader via insufficient URL origin validation

CVE-2026-26019GHSA-gf3v-fwqg-4vh7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@langchain/community 1.1.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-26019: 0.40% estimated exploitation activity in the next 30 days; percentile 34.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The RecursiveUrlLoader class in @langchain/community is a web crawler that recursively follows links from a starting URL. Its preventOutside option (enabled by default) is intended to restrict crawling to the same site as the base URL. The implementation used String.startsWith() to compare URLs, which does not perform semantic URL validation. An attacker who controls content on a crawled page could include links to domains that share a string prefix with the target (e.g., https://example.com.attacker.com passes a startsWith check against https://example.com), causing the crawler to follow links to attacker-controlled or internal infrastructure. Additionally, the crawler performed no validation against private or reserved IP addresses. A crawled page could include links targeting cloud metadata services (169.254.169.254), localhost, or RFC 1918 addresses, and the crawler would fetch them without restriction. Impact An attacker who can influence the content of a page being…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gf3v-fwqg-4vh7

  2. Revision 1 · created ·

    Published from osv record GHSA-gf3v-fwqg-4vh7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26019

Advisory: @langchain/community affected by SSRF Bypass in RecursiveUrlLoader via insufficient URL origin validation
IDs: CVE-2026-26019, GHSA-gf3v-fwqg-4vh7
Record: https://patchnext.com/advisories/cve-2026-26019 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @langchain/community 1.1.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @langchain/community: affected <= 1.1.13; fixed in 1.1.14

## Suggested inspection (read-only)
- `npm ls @langchain/community --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @langchain/community.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gf3v-fwqg-4vh7 (OSV record GHSA-gf3v-fwqg-4vh7 lists affected ranges: npm @langchain/community >=0 <1.1.14 (fixed))
- Verified: https://github.com/advisories/GHSA-gf3v-fwqg-4vh7 (GitHub-reviewed advisory GHSA-gf3v-fwqg-4vh7 lists affected ranges: npm @langchain/community >=0 <=1.1.13)

Commands are suggestions: review each one before running it.

Loading voting…