High, CVSS 8.4npmAmendedPublished
Jupyter Notebook Vulnerable to Authentication Token Theft via CommandLinker XSS
CVE-2026-40171 · GHSA-rch3-82jr-f9w9
- Affected
- npm @jupyter-notebook/help-extension >= 7.0.0, <= 7.5.5
- Fixed in
- 7.5.6· Vendor fix available
- Issue
- Impact A stored Cross-Site Scripting (XSS) vulnerability in Jupyter Notebook allows attackers to steal authentication tokens from users who open malicious notebook files and interact with elements that the attacker can make look indistinguishable from legitimate controls (single click interaction). The vulnerability enables complete account takeover through the Jupyter REST API, allowing the attacker to: 1. Read all files 2. Modify/create files 3. Access running kernels and execute arbitrary code 4. Create terminals for shell access Patches Jupyter Notebook 7.5.6 and JupyterLab 4.5.7 include patches for this vulnerability. Workarounds The help extension can be disabled via CLI: Hardening The patched versions include a toggle to disable the command linker functionality altogether, for example via overrides.json: Resources - https://jupyterlab.readthedocs.io/en/latest/user/commands.html#commands-in-markdown-output-and-files Acknowledgments Reported by Daniel Teixeira - NVIDIA AI Red Team
Recommended action: Upgrade to 7.5.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.