Jupyter Notebook Vulnerable to Authentication Token Theft via CommandLinker XSS
CVE-2026-40171GHSA-rch3-82jr-f9w9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@jupyter-notebook/help-extension 7.5.6; @jupyterlab/help-extension 4.5.7; jupyterlab 4.5.7; notebook 7.5.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @jupyter-notebook/help-extension
- Affected
- >= 7.0.0, <= 7.5.5
- Fixed in
- 7.5.6
npm @jupyterlab/help-extension
- Affected
- <= 4.5.6
- Fixed in
- 4.5.7
PyPI jupyterlab
- Affected
- <= 4.5.6
- Fixed in
- 4.5.7
PyPI notebook
- Affected
- >= 7.0.0, <= 7.5.5
- Fixed in
- 7.5.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rch3-82jr-f9w9 lists affected ranges: npm @jupyter-notebook/help-extension >=7.0.0 =7.0.0 =0 =0 <4.5.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rch3-82jr-f9w9 lists affected ranges: npm @jupyter-notebook/help-extension >=7.0.0 =7.0.0 =0 =0 <=4.5.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-40171: 0.48% estimated exploitation activity in the next 30 days; percentile 41.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A stored Cross-Site Scripting (XSS) vulnerability in Jupyter Notebook allows attackers to steal authentication tokens from users who open malicious notebook files and interact with elements that the attacker can make look indistinguishable from legitimate controls (single click interaction). The vulnerability enables complete account takeover through the Jupyter REST API, allowing the attacker to: 1. Read all files 2. Modify/create files 3. Access running kernels and execute arbitrary code 4. Create terminals for shell access Patches Jupyter Notebook 7.5.6 and JupyterLab 4.5.7 include patches for this vulnerability. Workarounds The help extension can be disabled via CLI: Hardening The patched versions include a toggle to disable the command linker functionality altogether, for example via overrides.json: Resources - https://jupyterlab.readthedocs.io/en/latest/user/commands.html#commands-in-markdown-output-and-files Acknowledgments Reported by Daniel Teixeira - NVIDIA AI Red Team
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rch3-82jr-f9w9
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-rch3-82jr-f9w9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40171 Advisory: Jupyter Notebook Vulnerable to Authentication Token Theft via CommandLinker XSS IDs: CVE-2026-40171, GHSA-rch3-82jr-f9w9 Record: https://patchnext.com/advisories/cve-2026-40171 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @jupyter-notebook/help-extension 7.5.6; @jupyterlab/help-extension 4.5.7; jupyterlab 4.5.7; notebook 7.5.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @jupyter-notebook/help-extension: affected >= 7.0.0, <= 7.5.5; fixed in 7.5.6 - npm @jupyterlab/help-extension: affected <= 4.5.6; fixed in 4.5.7 - PyPI jupyterlab: affected <= 4.5.6; fixed in 4.5.7 - PyPI notebook: affected >= 7.0.0, <= 7.5.5; fixed in 7.5.6 ## Suggested inspection (read-only) - `npm ls @jupyter-notebook/help-extension --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @jupyterlab/help-extension --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active. - `python -m pip show notebook`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @jupyter-notebook/help-extension, @jupyterlab/help-extension, jupyterlab, notebook. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rch3-82jr-f9w9 (OSV record GHSA-rch3-82jr-f9w9 lists affected ranges: npm @jupyter-notebook/help-extension >=7.0.0 =7.0.0 =0 =0 <4.5.7 (fixed)) - Verified: https://github.com/advisories/GHSA-rch3-82jr-f9w9 (GitHub-reviewed advisory GHSA-rch3-82jr-f9w9 lists affected ranges: npm @jupyter-notebook/help-extension >=7.0.0 =7.0.0 =0 =0 <=4.5.6) Commands are suggestions: review each one before running it.
Loading voting…