Skip to content

← Public intelligence

npm package

@evershop/evershop

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

9 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.1npmAmendedPublished

    EverShop at risk to unauthorized access via weak HMAC secret

    CVE-2023-46943 · GHSA-32r3-57hp-cgfw

    Affected
    • npm @evershop/evershop < 1.0.0-rc.9
    Fixed in
    1.0.0-rc.9· Vendor fix available
    Issue
    An issue was discovered in NPM's package @evershop/evershop before version 1.0.0-rc.9. The HMAC secret used for generating tokens is hardcoded as "secret". A weak HMAC secret poses a risk because attackers can use the predictable secret to create valid JSON Web Tokens (JWTs), allowing them access to important information and actions within the application.

    Recommended action: Upgrade to 1.0.0-rc.9 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5npmAmendedPublished

    EverShop vulnerable to improper authorization in GraphQL endpoints

    CVE-2023-46942 · GHSA-ggpm-9qfx-mhwg

    Affected
    • npm @evershop/evershop < 1.0.0-rc.9
    Fixed in
    1.0.0-rc.9· Vendor fix available
    Issue
    Lack of authentication in NPM's package @evershop/evershop before version 1.0.0-rc.9, allows remote attackers to obtain sensitive information via improper authorization in GraphQL endpoints.

    Recommended action: Upgrade to 1.0.0-rc.9 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.8npmAmendedPublished

    Code execution in evershop

    CVE-2023-46498 · GHSA-5mmr-9qx3-3pf9

    Affected
    • npm @evershop/evershop < 1.0.0-rc.8
    Fixed in
    1.0.0-rc.8· Vendor fix available
    Issue
    An issue in EverShop NPM versions before v.1.0.0-rc.8 allows a remote attacker to obtain sensitive information and execute arbitrary code via the /deleteCustomer/route.json file.

    Recommended action: Upgrade to 1.0.0-rc.8 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 6.1npmAmendedPublished

    Cross Site Scripting in evershop

    CVE-2023-46494 · GHSA-m6vm-ff9v-jp3r

    Affected
    • npm @evershop/evershop < 1.0.0-rc.5
    Fixed in
    1.0.0-rc.5· Vendor fix available
    Issue
    Cross Site Scripting vulnerability in EverShop NPM versions before v.1.0.0-rc.5 allows a remote attacker to obtain sensitive information via a crafted request to the ProductGrid function in admin/productGrid/Grid.jsx.

    Recommended action: Upgrade to 1.0.0-rc.5 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 5.4npmAmendedPublished

    Directory Traversal in evershop

    CVE-2023-46497 · GHSA-7443-5962-wp4r

    Affected
    • npm @evershop/evershop < 1.0.0-rc.8
    Fixed in
    1.0.0-rc.8· Vendor fix available
    Issue
    Directory Traversal vulnerability in EverShop NPM versions before v.1.0.0-rc.8 allows a remote attacker to obtain sensitive information via a crafted request to the mkdirSync function in the folderCreate/createFolder.js endpoint.

    Recommended action: Upgrade to 1.0.0-rc.8 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 6.1npmAmendedPublished

    Cross-site Scripting in evershop

    CVE-2023-46495 · GHSA-2xcj-557c-hf8r

    Affected
    • npm @evershop/evershop < 1.0.0-rc.8
    Fixed in
    1.0.0-rc.8· Vendor fix available
    Issue
    Cross Site Scripting vulnerability in EverShop NPM versions before v.1.0.0-rc.8 allows a remote attacker to obtain sensitive information via a crafted request to the sortBy parameter.

    Recommended action: Upgrade to 1.0.0-rc.8 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  7. High, CVSS 8.3npmAmendedPublished

    Directory Traversal in evershop

    CVE-2023-46496 · GHSA-rwf3-w4jq-f4cm

    Affected
    • npm @evershop/evershop < 1.0.0-rc.8
    Fixed in
    1.0.0-rc.8· Vendor fix available
    Issue
    Directory Traversal vulnerability in EverShop NPM versions before v.1.0.0-rc.8 allows a remote attacker to obtain sensitive information via a crafted request to the DELETE function in api/files endpoint.

    Recommended action: Upgrade to 1.0.0-rc.8 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  8. Medium, CVSS 5.3npmAmendedPublished

    Directory Traversal in evershop

    CVE-2023-46493 · GHSA-4wrm-qmq2-5fjx

    Affected
    • npm @evershop/evershop < 1.0.0-rc.8
    Fixed in
    1.0.0-rc.8· Vendor fix available
    Issue
    Directory Traversal vulnerability in EverShop NPM versions before v.1.0.0-rc.8 allows a remote attacker to obtain sensitive information via a crafted request to the readDirSync function in fileBrowser/browser.js.

    Recommended action: Upgrade to 1.0.0-rc.8 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  9. Medium, CVSS 6.1npmAmendedPublished

    Cross-site Scripting in evershop

    CVE-2023-46499 · GHSA-gjj8-m83c-qv9h

    Affected
    • npm @evershop/evershop < 1.0.0-rc.5
    Fixed in
    1.0.0-rc.5· Vendor fix available
    Issue
    Cross Site Scripting vulnerability in EverShop NPM versions before v.1.0.0-rc.5 allows a remote attacker to obtain sensitive information via a crafted scripts to the Admin Panel.

    Recommended action: Upgrade to 1.0.0-rc.5 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →