Directory Traversal in evershop
CVE-2023-46493GHSA-4wrm-qmq2-5fjx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@evershop/evershop 1.0.0-rc.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.0.0-rc.8
- Fixed in
- 1.0.0-rc.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4wrm-qmq2-5fjx lists affected ranges: npm @evershop/evershop >=0 <1.0.0-rc.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4wrm-qmq2-5fjx lists affected ranges: npm @evershop/evershop >=0 <1.0.0-rc.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-46493: 1.00% estimated exploitation activity in the next 30 days; percentile 62.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Directory Traversal vulnerability in EverShop NPM versions before v.1.0.0-rc.8 allows a remote attacker to obtain sensitive information via a crafted request to the readDirSync function in fileBrowser/browser.js.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4wrm-qmq2-5fjx
- Revision 1 · created ·
Published from osv record GHSA-4wrm-qmq2-5fjx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-46493 Advisory: Directory Traversal in evershop IDs: CVE-2023-46493, GHSA-4wrm-qmq2-5fjx Record: https://patchnext.com/advisories/cve-2023-46493 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @evershop/evershop 1.0.0-rc.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @evershop/evershop: affected < 1.0.0-rc.8; fixed in 1.0.0-rc.8 ## Suggested inspection (read-only) - `npm ls @evershop/evershop --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @evershop/evershop. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4wrm-qmq2-5fjx (OSV record GHSA-4wrm-qmq2-5fjx lists affected ranges: npm @evershop/evershop >=0 <1.0.0-rc.8 (fixed)) - Verified: https://github.com/advisories/GHSA-4wrm-qmq2-5fjx (GitHub-reviewed advisory GHSA-4wrm-qmq2-5fjx lists affected ranges: npm @evershop/evershop >=0 <1.0.0-rc.8) Commands are suggestions: review each one before running it.
Loading voting…