High, CVSS 8.6npmAmendedPublished
DuckDB NPM packages 1.3.3 and 1.29.2 briefly compromised with malware
CVE-2025-59037 · GHSA-w62p-hx95-gf2c
- Affected
- npm @duckdb/duckdb-wasm >= 1.29.2, <= 1.29.2
- Fixed in
- 1.30.0· Vendor fix available
- Issue
- The DuckDB distribution for Node.js on npm was compromised with malware (along with several other packages). An attacker published new versions of four of duckdb’s packages that included malicious code to interfere with cryptocoin transactions. The following packages and versions are affected: - @duckdb/node-api@1.3.3 - @duckdb/node-bindings@1.3.3 - duckdb@1.3.3 - @duckdb/duckdb-wasm@1.29.2 Note: The current release version of DuckDB is 1.3.2, with 1.4.0 expected to be released on Sept 10th, 2025 (tomorrow as of this writing). We do not plan to ever release a “legit” DuckDB 1.3.3. Users should double-check that they are not accidentally updating to those affected versions. We have ourselves noticed this within four hours of it happening. Here’s our response: - As an immediate response, we have deprecated the specific versions. - We have reached out to npm support to delete the affected versions. They were so kind to do so. - We have also re-released the node packages with higher…
Recommended action: Upgrade to 1.30.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.