DuckDB NPM packages 1.3.3 and 1.29.2 briefly compromised with malware
CVE-2025-59037GHSA-w62p-hx95-gf2c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (duckdb 1.3.4; @duckdb/duckdb-wasm 1.30.0; @duckdb/node-api 1.3.4-alpha.27; @duckdb/node-bindings 1.3.4-alpha.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm duckdb
- Affected
- >= 1.3.3, <= 1.3.3
- Fixed in
- 1.3.4
- Affected
- >= 1.29.2, <= 1.29.2
- Fixed in
- 1.30.0
npm @duckdb/node-api
- Affected
- >= 1.3.3, <= 1.3.3
- Fixed in
- 1.3.4-alpha.27
- Affected
- >= 1.3.3, <= 1.3.3
- Fixed in
- 1.3.4-alpha.27
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w62p-hx95-gf2c lists affected ranges: npm duckdb >=1.3.3 =1.3.3 =1.3.3 =1.29.2 <1.30.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w62p-hx95-gf2c lists affected ranges: npm duckdb >=1.3.3 =1.3.3 =1.3.3 =1.29.2 <=1.29.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2025-59037: 0.37% estimated exploitation activity in the next 30 days; percentile 31.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The DuckDB distribution for Node.js on npm was compromised with malware (along with several other packages). An attacker published new versions of four of duckdb’s packages that included malicious code to interfere with cryptocoin transactions. The following packages and versions are affected: - @duckdb/node-api@1.3.3 - @duckdb/node-bindings@1.3.3 - duckdb@1.3.3 - @duckdb/duckdb-wasm@1.29.2 Note: The current release version of DuckDB is 1.3.2, with 1.4.0 expected to be released on Sept 10th, 2025 (tomorrow as of this writing). We do not plan to ever release a “legit” DuckDB 1.3.3. Users should double-check that they are not accidentally updating to those affected versions. We have ourselves noticed this within four hours of it happening. Here’s our response: - As an immediate response, we have deprecated the specific versions. - We have reached out to npm support to delete the affected versions. They were so kind to do so. - We have also re-released the node packages with higher…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w62p-hx95-gf2c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w62p-hx95-gf2c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59037 Advisory: DuckDB NPM packages 1.3.3 and 1.29.2 briefly compromised with malware IDs: CVE-2025-59037, GHSA-w62p-hx95-gf2c Record: https://patchnext.com/advisories/cve-2025-59037 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: duckdb 1.3.4; @duckdb/duckdb-wasm 1.30.0; @duckdb/node-api 1.3.4-alpha.27; @duckdb/node-bindings 1.3.4-alpha.27. A vendor fix does not mean a deployment is fixed. ## Affected components - npm duckdb: affected >= 1.3.3, <= 1.3.3; fixed in 1.3.4 - npm @duckdb/duckdb-wasm: affected >= 1.29.2, <= 1.29.2; fixed in 1.30.0 - npm @duckdb/node-api: affected >= 1.3.3, <= 1.3.3; fixed in 1.3.4-alpha.27 - npm @duckdb/node-bindings: affected >= 1.3.3, <= 1.3.3; fixed in 1.3.4-alpha.27 ## Suggested inspection (read-only) - `npm ls duckdb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @duckdb/duckdb-wasm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @duckdb/node-api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @duckdb/node-bindings --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on duckdb, @duckdb/duckdb-wasm, @duckdb/node-api, @duckdb/node-bindings. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w62p-hx95-gf2c (OSV record GHSA-w62p-hx95-gf2c lists affected ranges: npm duckdb >=1.3.3 =1.3.3 =1.3.3 =1.29.2 <1.30.0 (fixed)) - Verified: https://github.com/advisories/GHSA-w62p-hx95-gf2c (GitHub-reviewed advisory GHSA-w62p-hx95-gf2c lists affected ranges: npm duckdb >=1.3.3 =1.3.3 =1.3.3 =1.29.2 <=1.29.2) Commands are suggestions: review each one before running it.
Loading voting…