High, CVSS 8.1npmAmendedPublished
@cyclonedx/cyclonedx-library Improper Restriction of XML External Entity Reference vulnerability
CVE-2024-34345 · GHSA-38gf-rh2w-gmj7
- Affected
- npm @cyclonedx/cyclonedx-library >= 6.7.0, <= 6.7.0
- Fixed in
- 6.7.1· Vendor fix available
- Issue
- Impact XML External entity injections could be possible, when running the provided XML Validator on arbitrary input. POC Patches This issue was fixed in @cyclonedx/cyclonedx-library@6.7.1 . Workarounds Do not run the provided XML validator on untrusted inputs. References issue was introduced via <https://github.com/CycloneDX/cyclonedx-javascript-library/pull/1063.
Recommended action: Upgrade to 6.7.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.