@cyclonedx/cyclonedx-library Improper Restriction of XML External Entity Reference vulnerability
CVE-2024-34345GHSA-38gf-rh2w-gmj7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@cyclonedx/cyclonedx-library 6.7.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @cyclonedx/cyclonedx-library
- Affected
- >= 6.7.0, <= 6.7.0
- Fixed in
- 6.7.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-38gf-rh2w-gmj7 lists affected ranges: npm @cyclonedx/cyclonedx-library >=6.7.0 <6.7.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-38gf-rh2w-gmj7 lists affected ranges: npm @cyclonedx/cyclonedx-library >=6.7.0 <=6.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-34345: 0.92% estimated exploitation activity in the next 30 days; percentile 60.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact XML External entity injections could be possible, when running the provided XML Validator on arbitrary input. POC Patches This issue was fixed in @cyclonedx/cyclonedx-library@6.7.1 . Workarounds Do not run the provided XML validator on untrusted inputs. References issue was introduced via <https://github.com/CycloneDX/cyclonedx-javascript-library/pull/1063.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-38gf-rh2w-gmj7
- Revision 1 · created ·
Published from osv record GHSA-38gf-rh2w-gmj7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34345 Advisory: @cyclonedx/cyclonedx-library Improper Restriction of XML External Entity Reference vulnerability IDs: CVE-2024-34345, GHSA-38gf-rh2w-gmj7 Record: https://patchnext.com/advisories/cve-2024-34345 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @cyclonedx/cyclonedx-library 6.7.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @cyclonedx/cyclonedx-library: affected >= 6.7.0, <= 6.7.0; fixed in 6.7.1 ## Suggested inspection (read-only) - `npm ls @cyclonedx/cyclonedx-library --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @cyclonedx/cyclonedx-library. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-38gf-rh2w-gmj7 (OSV record GHSA-38gf-rh2w-gmj7 lists affected ranges: npm @cyclonedx/cyclonedx-library >=6.7.0 <6.7.1 (fixed)) - Verified: https://github.com/advisories/GHSA-38gf-rh2w-gmj7 (GitHub-reviewed advisory GHSA-38gf-rh2w-gmj7 lists affected ranges: npm @cyclonedx/cyclonedx-library >=6.7.0 <=6.7.0) Commands are suggestions: review each one before running it.
Loading voting…