Skip to content

← Public intelligence

npm package

@cubejs-backend/server-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5npmAmendedPublished

    Cube Core is vulnerable to Denial of Service (DoS) via crafted request

    CVE-2026-25957 · GHSA-9vph-2hvm-x66g

    Affected
    • npm @cubejs-backend/server-core >= 1.1.17, < 1.4.2; >= 1.5.0, < 1.5.13
    Fixed in
    1.4.21.5.13· Vendor fix available
    Issue
    Impact It is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. Affected Versions: = 1.1.17 Mitigation: Upgrade to a patched version: - 1.5.13 and later (regular release) - 1.4.2 (active LTS release) References The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.

    Recommended action: Upgrade to 1.5.13 or 1.4.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.7npmAmendedPublished

    Cube Core is vulnerable to privilege escalation via a specially crafted request

    CVE-2026-25958 · GHSA-v226-32c7-x2v7

    Affected
    • npm @cubejs-backend/server-core >= 0.27.19, < 1.0.14; >= 1.1.0, < 1.4.2; >= 1.5.0, < 1.5.13
    Fixed in
    1.4.21.5.131.0.14· Vendor fix available
    Issue
    Impact It is possible to make a specially crafted request with a valid API token that leads to privilege escalation. Affected Versions: ≥= 0.27.19 Mitigation: Upgrade to a patched version: - 1.5.13 and later (regular release) - 1.4.2 (active LTS release) - 1.0.14 (end-of-life LTS release) References The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.

    Recommended action: Upgrade to 1.5.13, 1.4.2 or 1.0.14 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →