Cube Core is vulnerable to Denial of Service (DoS) via crafted request
CVE-2026-25957GHSA-9vph-2hvm-x66g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@cubejs-backend/server-core 1.5.13, 1.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @cubejs-backend/server-core
- Affected
- >= 1.1.17, < 1.4.2>= 1.5.0, < 1.5.13
- Fixed in
- 1.4.2, 1.5.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9vph-2hvm-x66g lists affected ranges: npm @cubejs-backend/server-core >=1.1.17 =1.5.0 <1.5.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9vph-2hvm-x66g lists affected ranges: npm @cubejs-backend/server-core >=1.1.17 =1.5.0 <1.5.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-25957: 0.44% estimated exploitation activity in the next 30 days; percentile 38.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. Affected Versions: = 1.1.17 Mitigation: Upgrade to a patched version: - 1.5.13 and later (regular release) - 1.4.2 (active LTS release) References The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9vph-2hvm-x66g
- Revision 1 · created ·
Published from osv record GHSA-9vph-2hvm-x66g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25957 Advisory: Cube Core is vulnerable to Denial of Service (DoS) via crafted request IDs: CVE-2026-25957, GHSA-9vph-2hvm-x66g Record: https://patchnext.com/advisories/cve-2026-25957 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @cubejs-backend/server-core 1.5.13, 1.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @cubejs-backend/server-core: affected >= 1.1.17, < 1.4.2; >= 1.5.0, < 1.5.13; fixed in 1.4.2, 1.5.13 ## Suggested inspection (read-only) - `npm ls @cubejs-backend/server-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @cubejs-backend/server-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9vph-2hvm-x66g (OSV record GHSA-9vph-2hvm-x66g lists affected ranges: npm @cubejs-backend/server-core >=1.1.17 =1.5.0 <1.5.13 (fixed)) - Verified: https://github.com/advisories/GHSA-9vph-2hvm-x66g (GitHub-reviewed advisory GHSA-9vph-2hvm-x66g lists affected ranges: npm @cubejs-backend/server-core >=1.1.17 =1.5.0 <1.5.13) Commands are suggestions: review each one before running it.
Loading voting…