Skip to content

← Public intelligence

npm package

@chainsafe/libp2p-noise

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1npmAmendedPublished

    Failure to validate signature during handshake

    CVE-2022-24759 · GHSA-j3ff-xp6c-6gcc

    Affected
    • npm @chainsafe/libp2p-noise < 4.1.2; >= 5.0.0, < 5.0.3
    Fixed in
    4.1.25.0.3· Vendor fix available
    Issue
    Impact @chainsafe/libp2p-noise before 4.1.2 and 5.0.3 was not correctly validating signatures during the handshake process. This may allow a man-in-the-middle to pose as other peers and get those peers banned. Patches Users should upgrade to 4.1.2 or 5.0.3 Workarounds No workarounds, just patch upgrade References https://github.com/ChainSafe/js-libp2p-noise/pull/130

    Recommended action: Upgrade to 5.0.3 or 4.1.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →