Failure to validate signature during handshake
CVE-2022-24759GHSA-j3ff-xp6c-6gcc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@chainsafe/libp2p-noise 5.0.3, 4.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 4.1.2>= 5.0.0, < 5.0.3
- Fixed in
- 4.1.2, 5.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j3ff-xp6c-6gcc lists affected ranges: npm @chainsafe/libp2p-noise >=0 =5.0.0 <5.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3ff-xp6c-6gcc lists affected ranges: npm @chainsafe/libp2p-noise >=0 =5.0.0 <5.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2022-24759: 0.50% estimated exploitation activity in the next 30 days; percentile 42.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact @chainsafe/libp2p-noise before 4.1.2 and 5.0.3 was not correctly validating signatures during the handshake process. This may allow a man-in-the-middle to pose as other peers and get those peers banned. Patches Users should upgrade to 4.1.2 or 5.0.3 Workarounds No workarounds, just patch upgrade References https://github.com/ChainSafe/js-libp2p-noise/pull/130
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-j3ff-xp6c-6gcc
- Revision 1 · created ·
Published from osv record GHSA-j3ff-xp6c-6gcc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24759 Advisory: Failure to validate signature during handshake IDs: CVE-2022-24759, GHSA-j3ff-xp6c-6gcc Record: https://patchnext.com/advisories/cve-2022-24759 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @chainsafe/libp2p-noise 5.0.3, 4.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @chainsafe/libp2p-noise: affected < 4.1.2; >= 5.0.0, < 5.0.3; fixed in 4.1.2, 5.0.3 ## Suggested inspection (read-only) - `npm ls @chainsafe/libp2p-noise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @chainsafe/libp2p-noise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j3ff-xp6c-6gcc (OSV record GHSA-j3ff-xp6c-6gcc lists affected ranges: npm @chainsafe/libp2p-noise >=0 =5.0.0 <5.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-j3ff-xp6c-6gcc (GitHub-reviewed advisory GHSA-j3ff-xp6c-6gcc lists affected ranges: npm @chainsafe/libp2p-noise >=0 =5.0.0 <5.0.3) Commands are suggestions: review each one before running it.
Loading voting…