Critical, CVSS 9.8npmAmendedPublished
CASL Ability is Vulnerable to Prototype Pollution
CVE-2026-1774 · GHSA-x9vf-53q3-cvx6
- Affected
- npm @casl/ability >= 2.4.0, <= 6.7.4
- Fixed in
- 6.7.5· Vendor fix available
- Issue
- CASL Ability, versions 2.4.0 through 6.7.4, contains a prototype pollution vulnerability.
Recommended action: Upgrade to 6.7.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.