CASL Ability is Vulnerable to Prototype Pollution
CVE-2026-1774GHSA-x9vf-53q3-cvx6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@casl/ability 6.7.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @casl/ability
- Affected
- >= 2.4.0, <= 6.7.4
- Fixed in
- 6.7.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x9vf-53q3-cvx6 lists affected ranges: npm @casl/ability >=2.4.0 <=6.7.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x9vf-53q3-cvx6 lists affected ranges: npm @casl/ability >=2.4.0 <6.7.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-1774: 0.71% estimated exploitation activity in the next 30 days; percentile 53.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
CASL Ability, versions 2.4.0 through 6.7.4, contains a prototype pollution vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-x9vf-53q3-cvx6
- Revision 2 · amended ·
Amended from osv record GHSA-x9vf-53q3-cvx6
- Revision 1 · created ·
Published from ghsa record GHSA-x9vf-53q3-cvx6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-1774 Advisory: CASL Ability is Vulnerable to Prototype Pollution IDs: CVE-2026-1774, GHSA-x9vf-53q3-cvx6 Record: https://patchnext.com/advisories/cve-2026-1774 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @casl/ability 6.7.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @casl/ability: affected >= 2.4.0, <= 6.7.4; fixed in 6.7.5 ## Suggested inspection (read-only) - `npm ls @casl/ability --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @casl/ability. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x9vf-53q3-cvx6 (GitHub-reviewed advisory GHSA-x9vf-53q3-cvx6 lists affected ranges: npm @casl/ability >=2.4.0 <=6.7.4) - Verified: https://osv.dev/vulnerability/GHSA-x9vf-53q3-cvx6 (OSV record GHSA-x9vf-53q3-cvx6 lists affected ranges: npm @casl/ability >=2.4.0 <6.7.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…