Critical, CVSS 9.6npmAmendedPublished
Supply chain compromise via malicious @cap-js/openapi
GHSA-jpvj-wpmj-h7rv
- Affected
- npm @cap-js/openapi >= 1.4.1, <= 1.4.1
- Fixed in
- 1.4.2· Vendor fix available
- Issue
- Impact On May 19, 2026, a compromised version of @cap-js/openapi@1.4.1 was published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. Patches Upgrade to @cap-js/openapi = 1.4.2 If the compromised version was ever installed, rotate all affected credentials. Workarounds No workarounds. References - SAP Note 3747787 - Developer FAQ
Recommended action: Upgrade to 1.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.